Blank Document id for CustomBod

I have tried creating a custom bod in our Cloudsuite Food & Beverage. I have manage to get it working through the whole flow but in OneView, the document id is blank.

I have configuered the identifier path in the object schema but still it is not picked up.

This is how it looks like in OneView:

I have attached an export of the Schema as well.

CustomCustomer.zip

Am I missing something in the setup?

  • Hello,

    This is working here :

     

    How did you defined your file connection point ? Are you using a file template or a full document ?

  • In reply to Maxime R.:

    Hi,

    The file definintion in the connection point was the full document, but I also tried to change it to File format but with the same result.

    However, if I create an xml file according to the file template format (only containing the information in the CustomerData tag), then I also get it to work. But in my scenario I want M3 to create a custom BOD through IEC and in this case the full BOD format is required in order to pass it into ION since it is using the IObox. In this case I do not get it to work.

    This is and example file that was created by M3:

    CustomCustomerExample.xml
    <?xml version="1.0" encoding="UTF-8" ?>
    <SyncCustomCustomer xmlns="http://schema.infor.com/InforOAGIS/2" releaseID="9.2" versionID="2.12.1" systemEnvironmentCode="Production">
    	<ApplicationArea>
    		<Sender>
    			<LogicalID schemeVersionID="3">lid://infor.m3.m3</LogicalID>
    			<ComponentID schemeVersionID="16.0.0.20190922120042">M3BE</ComponentID>
    			<ConfirmationCode>OnError</ConfirmationCode>
    		</Sender>
    		<CreationDateTime>2019-11-07T10:58:18.696Z</CreationDateTime>
    		<BODID>1d45f374-b690-4a99-8915-ddbf6cfc3e97</BODID>
    	</ApplicationArea>
    	<DataArea>
    		<Sync>
    			<ActionCriteria>Replace</ActionCriteria>
    		</Sync>
    		<CustomCustomer>
    			<CustomerData>
    				<CustomerNumber>11009-1</CustomerNumber>
    				<CustomerName>Customer A-8 AD</CustomerName>
    				<Status>20</Status>
    			</CustomerData>
    		</CustomCustomer>
    	</DataArea>
    </SyncCustomCustomer>

  • In reply to DHenningsverEG:

    I suspect the default namespace.

    Can you check your agreement in MEC and activate parameter "Do not write namespaces of output file" on the "XML transform" step?

     

    Save, reload cache, retry.

  • In reply to Maxime R.:

    We are running MT Cloud so Parter Admin is no longer in use. I tried to remove the namespace in the following parameter but it didn't help:

  • In reply to DHenningsverEG:

    I think that if you remove this parameter, IEC will write an empty namespace xmlns="".

    Can you have a look at the customBOD before sending it to the outbox ?
  • In reply to Maxime R.:

    I'm not sure how to check this in M3 CE. I will see if I can figure it out, if it is possible.
  • In reply to DHenningsverEG:

    Hi - the Document ID is picked up from connector based on the schema for technology connectors (and yours looks fine), but for an IOBox connection it gets the value from the COR_OUTBOX_HEADER table. You might validate that this is happening correctly by taking a look at the header table. (note: normally this is set up to have records removed after pick up, so you may need to change that to be able to 'catch' one in action). Good luck.
  • In reply to davidjpeters:

    Hi,

    There we have it. Based on your answer I managed to locate a function in IEC mapper to set the Document id in the OutBoxHeaderData and now it works.

    Thank you both for the help you provided.