Infor OS update Issue with ION API Service



We have a customer who have faced the issue with updating Infor os without stopped the ION Api Service.


Now the Service is corrupt. 

We try to remove and re-install with the Service with nssm64.exe.

Now the Service is running again but we have the issue that ION API cannot load the API definition under "API Metadata".


The error "Failed to fetch" accours.

Trying to open the URL results in connection refused.


Have anybody an idea to fix the corrupt service problem or why we can load the metadata?

Everything works great before this update issue?


thx a lot for any response! 

  • Hi, what was the starting version and what is the target version of Infor OS.
    We faced the same going from 12.0.28 to 12.0.30. The solution was to reinstall Elastic search service manually and then update the Elastic search templates, and at the end also renewing OAuth keys. Elastic search templates update procedure worked in 12.0.30, but not in 12.0.32 (because something in Elastic search configuration has changed).
  • In reply to Tilen Markez:

    The update path was 12.0.28 - 12.0.30 - 12.0.32 - 12.0.37.
    On which step the service became corrupt is not known.

    How do you managed to resinstall the ES Service and update the search templates?

    Wich OAuth keys do you renew? The IONAPITokenForIONServices?

    I find no documents concerning to reinstall a single step of an Infor OS installation...
  • In reply to BE-terna - Thomas A.:

    Ok, now i found the elasticsearch-service.bat with the switches install, remove... and so on unter X:\OS\Services\EnterpriseSearch\bin

    But i have no clue how to update the search templates?
  • In reply to BE-terna - Thomas A.:

    Below are the KBs you are looking for. Both will help with search and IONAPI service. For the oauth credentials, you can run the version setup.exe switch.

    KB1934131 - IONGateway creation.

    KB2024641 - Search Templates.

    setup.exe -v"RENEWGRIDOAUTHKEYS=true"
  • In reply to Brandon Watson:

    Hi, as Brandon said..

    It is not just running elasticsearch-service.bat. It is more complicated, for template updates you need to run Postman and send jsons to some REST endpoints on port 9200.

    KB 1934131 and 2024641 are not available to everybody, at least I don't have access to it. We got KBs from another source/partner and made the needed steps in 12.0.30 (which was the last version described in it).. We have the same problem with 12.0.37 at another customer, and we are not able to get anything near the solution. Please let me know, if this KB's include anything regarding 12.0.32 and 12.0.37. thanks.
  • In reply to Tilen Markez:

    Tilen - Yes, Infor has updated both for .32 and .37. I was worried about the access, but thought they had opened it up to everyone. If not, then you should be able to contact support to get help. Or contact a partner that has the documentation.
  • In reply to Brandon Watson:

    Thx a lot Brandon, you are a master of Infor KB Search...
    now i know why i am not able to find something about nssm64... the KB Speaks from mssm64.exe.

    I was able to reinstall the Gateway Service. I run the setup again...

    After i restart the server and see that the error persists i am discover that no service is listening on port 7443 for the metadata...

    Any ideas to this?
  • In reply to BE-terna - Thomas A.:

    Ok... i also see that only one node.js Server Process is running and not the IONApiGateway Services for each processor as descriped in the KB Document.
  • In reply to BE-terna - Thomas A.:

    Try running
    setup.exe -v"UPDATECERTIFICATES=true"
    It helped in one of our case, I don't know why though.
  • In reply to BE-terna - Thomas A.:

    You will want to look at the C:\ProgramData\Infor\IONGateway folder for answers in the log file. The only thing i can think of is the grid-enablement.jar. That may be linked to this, but I have not confirmed that.
  • In reply to Brandon Watson:

    I will take advantage of the thread as it is open already, hope you don't mind.

    Brandon - in a documentation that I've got in the past regarding pushing templates to Elastic search it was said that we should check the availability going to http://<hostname>:9200/_template, and later on checking http://<hostname>/_cluster/settings and then sending new templates using PUT request. For me it worked in 12.0.30 but not in 12.0.32/37. Seems to me that port 9200 uses SSL protocol now (and I would say that also because in elasticsearch.yaml there are lines describing certificates, etc). And if I go to https://<hostname>/_cluster/settings, it asks for username and password (if I use a browser that can go beyond non trusted certificate that this service uses, does anyone know, what it expects for user/pass). I had a session with Infor Support and they desperately tried to go to http address and see that it does not work there and ending up, that installation is fault and I should reinstall the whole Infor OS.. But the fact is that this address on http does not work the way they tried even on fresh installations of 12.0.32 or 12.0.37 (I have tried that at other customer, that didn't went through upgrade process).
  • In reply to Tilen Markez:

    Tilen - I added this to my doc in .32. They added searchguard to secure elastic, for Infor OS, over HTTPS. In the Farm.ServiceConfigurationDetail table you will find 3 records that have admin for the ConfigValue. The next record will have the password. Use that admin/password combo to get logged in. if you are using Postman, use Basic Auth for the Authorization.

    3) Check gateway template is in correct version (use the URL for the environment you are working with to replace the hostname here): , we can see template as empty or in some cases template is present and it will be in older version (i.e type value with String)
    a. May need to use basic auth for Infor OS 12.0.32+
    i. Infor_OS_Farm.dbo.ServiceConfigurationDetail – admin – next record password
  • In reply to Brandon Watson:

    Hi, thank you very much. This is very valuable information. Finally found that templates in 12.0.32 and they are wrong, using string type instead of type keyword..
  • In reply to Tilen Markez:

    I would be careful about the IONAPIGATEWAY. All of my .32/.37 customers have string in this template, and are working. If you need a copy of my .32/.37 template, for this, let me know.
  • In reply to Brandon Watson:

    Hi, yes, if it is available, please send it to me. I have checked two systems and it seems "misconfigured" 12.0.32 seems to have the same ionapigateway json as "working" 12.0.37. I didn't compare the rest templates. I have seen that gateway_tracing is replaced with another one in 12.0.37.